• June 3, 2018 at 18:54 #5222

    Hey folks!

    I also submitted a support ticket… but I’m having an issue with a mac mini running Live Professor introducing intermittent clicks every few minutes into the return paths. IE, I use simple chains for Vox hardware inserts via Rednet PCie in a thunderbolt chassis, connected to a dLive via Dante. I have one system at our primary campus, completely identical to the one that I’m having issues with, running a buffer of 64 samples. Both the primary campus and secondary campus mac mini units are same 2011 i7 chipset, 8gB ram, and OS (Sierra 10.12.6.)

    I’m trying to track what might be causing an intermittent click. I’ve gone through every darn setting and it keeps happening. Buffer alteration doesn’t make it go away (even with an absurdly large one.)

    …so I’m wondering: does Live Professor support 32-bit float? There does *not* appear to be a bit-depth option anywhere in the audio/midi options, so I’ve never thought to look at it.

    I noticed that the rednet pcie at our second campus is locked to 48k/32 bit float. I did not have an opportunity to compare the primary campus, but I suspect it’s running 24 bit.

    June 4, 2018 at 08:39 #5230


    The audio engine is 32bit float from start to end, except in some special cases where it is 64bit float.

    That said, maybe this is a compatibility issue with the rednet pci device. Worth a check for sure.

    There are plenty of Dante users here that could maybe verify this?

    June 5, 2018 at 22:08 #5241

    Okay good to know! Thanks for ruling out a bit-depth issue!

    I doubt it’s a PCIe compatibility issue. We’ve been running the same card, with the same model mac mini, at our primary venue for well over a year with no issues. (I’ve taxed that machine like crazy too: Osculator running a ton of real-time midi/lighting triggers, Ableton running additional cues, Spotify also running on Dante Via, all while Live Professor is still handling inserts. That particular show I think I even had like 12 chains in LP.)

    As a test for that very thing, This last Sunday I ran Reaper simultaneously to capture both the individual multitrack tracks, as well as a 2-track Dante return from the dLive. 2-track included the active inserts from Live Professor. Reaper runs on that same mac mini using the RedNet PCIe.

    Notably, there were zero clicks, pops, or other artifacts in the individual Reaper tracks; however, there were audible clicks, as well as visible accompanied transients in the 2-track mix, but only while Live Professor was active on insert! That tells me there is some kind of software thing happening *specifically* with Live Professor, or at the very least, on the *output* side of the PCIe.

    I also have several multi-track sessions specifically designed for playback *to* the dLive over the Rednet PCIe card. I’ve been using them for training, as well as just for fun when I have some down time to play with desk features. Playback with those Reaper sessions resulted in zero pops/clicks etc. Further suggesting something in the LP software interface, or possibly in how Sierra is handling the processing, is causing the clicks.

    It is extraordinarily confusing and irritating to say the least! I did get your email response to my inquiry about the clicks. Will be back at the venue this weekend and will have a chance to manually turn off *all* app naps for that machine via terminal, so will see if that resolves the issue. Will keep you posted on results!

    June 9, 2018 at 07:33 #5244

    Thank you for the detailed information.
    You could also try to run a project with empty chains, (with out any plugins) and see if the error is there still.
    Kind of figure out if it is due to a plugin, general processor load or what.

    June 10, 2018 at 11:41 #5245

    Alas, the clicks are persisting.

    I have disabled App Nap completely, I have tried running LP over Dante Via/DVS as opposed to over the PCIE card to test audio interface options. I have tried running each of those options with, and without plugins in the chains, I have attempted to connect directly to the console, bypassing network switch entirely, and we are still getting a random click every few minutes.

    I have tried resetting pRam and SMC. I have double-checked clock settings, I have ensured all devices are running @ the same sample rate, and so forth.

    I’m kind of at a loss for additional things to try at this point.

    My *one* final test will be to set up a Reaper session to try to run the same plugs as audio insert, with the same latency settings to confirm that LP is, in fact the source. (Buffer didn’t affect it though, so…?)

You must be logged in to reply to this topic.