BSOD portcls.sys

Everything about LiveProfessor.
Ideas, bug reports, tips & trix
anwaypasible
Posts: 125
Joined: Tue Sep 04, 2012 8:59 am
Location: kankakee illinois
Contact:

BSOD portcls.sys

Postby anwaypasible » Sun Jun 16, 2013 12:16 am

i know you said portcls.sys isn't used by live professor .. but it also isn't used by virtual audio cable when there is an option there to specifically use it or not (mine is set to not use it)
so does this leave asio4all as the culprit .?
it seems it is the last piece in the chain unaccounted for.

i've experienced two different types of portcls.sys crashes.
one is a random bsod
the other is when the DSP usage gets up near 100% and the asio4all is flipping back and forth between 'okay' and 'not okay'
(because if any chunk is processable, why not all of them?!)

even though this isn't liveprofessor's fault, as you said, can you still help with some explanation or insight or advice or SOMETHING?
not only is it annoying, i am finding it a bit violent.

i don't get much peace & rest .. and when things go wrong, it pushes on nearly impossible causing a larger distance between me & peace|rest as if a ratio higher & greater than the course my will was set on.
anwaypasible
Posts: 125
Joined: Tue Sep 04, 2012 8:59 am
Location: kankakee illinois
Contact:

Postby anwaypasible » Mon Jun 17, 2013 3:39 am

i was trying to ask..

is there a virtual environment i can run the programs in to catch the problem?
or is there some program that can track the issue?


i just had another crash and the audio wasnt skipping.. but the mouse slowed down to a halt and then the screen flashed blue.
anwaypasible
Posts: 125
Joined: Tue Sep 04, 2012 8:59 am
Location: kankakee illinois
Contact:

Postby anwaypasible » Mon Jun 17, 2013 10:50 pm

something is clearly upset (wrong)

i installed this operating system fresh on 4-11-2013
usually i run asio4all at 512 samples and it doesnt stutter .. but now i am running it at 2048 and there is stuttering.

obviously whatever the problem is, it is dynamic and punctual enough to crash the computer.
i know i'm not going to be the only one using asio4all with liveprofessor .. i'd feel better knowing their experience isn't burdened by function problems.

(i went back to kefir convolution plugin because it sounds where reverberate is bright and flake-y)
i learned i can turn the mix knob up to 100% using headphones ... but doing the same thing for the floorstanding speakers causes the room to show its echo.
mr-es335
Posts: 120
Joined: Wed Jan 23, 2013 1:18 pm
Location: Canada
Contact:

Postby mr-es335 » Mon Jun 17, 2013 11:39 pm

Hello,

I am not sure what your problem is....mostly for testing purposes - as I am <b>VERY</b> particular on how installs go.

I use ASIO4ALL on my test system all of the time.

In this regard, LiveProfessor works like an absolute charm here!

But I have installed so many times now - and have never any "real" concerns. There just <b>has</b> to be other issues.

Mr. es-335
http://www.sentinelmusicstudios.com
User avatar
nikolai
Posts: 1231
Joined: Fri Sep 04, 2009 1:05 pm
Location: Norway
Contact:

Postby nikolai » Tue Jun 18, 2013 12:00 am

If you google "portcl.sys bsod" you will get plenty of info on this issue. It is audio driver related.
Are you using the internal soundcard? I would recommend disabling it and getting something more stable.
http://www.rme-audio.de/en_products_babyface.php
anwaypasible
Posts: 125
Joined: Tue Sep 04, 2012 8:59 am
Location: kankakee illinois
Contact:

Postby anwaypasible » Tue Jun 18, 2013 3:14 am

thanks for the nudge you two.

i'm using a creative x-fi elite pro with the 'pax' modified drivers.
the only reason why i was using the pax drivers was because the THX studio that comes with the xfi card stopped working as it doesn't install on windows 7
yet the pax version of drivers had a version of thx studio that installs.
i guess i can get rid of the pax drivers and switch back to the official creative drivers, then use some delay vst plugin to replace it.
anwaypasible
Posts: 125
Joined: Tue Sep 04, 2012 8:59 am
Location: kankakee illinois
Contact:

Postby anwaypasible » Sat Feb 22, 2014 5:00 pm

just had a crash using the creative asio drivers, rules out asio4all as the problem.
was using the latest 32bit version.

maybe my soundcard is going bad, but i've used vsthost without bsod .. however vsthost does crash from time to time.

i really hate to be a burden.
User avatar
nikolai
Posts: 1231
Joined: Fri Sep 04, 2009 1:05 pm
Location: Norway
Contact:

Postby nikolai » Tue Feb 25, 2014 12:42 am

Sorry, I'm lost on this. Can't see other then that is has to be hardware related.
anwaypasible
Posts: 125
Joined: Tue Sep 04, 2012 8:59 am
Location: kankakee illinois
Contact:

Postby anwaypasible » Sat Mar 01, 2014 6:18 pm

the other day i rebooted and i was getting an installer for device drivers (the auto install for plugging in new hardware).
it was hanging up and causing my whole system to run slow.
upon telling the computer to restart, i seen 'creative' listed in the programs waiting to close.
so i removed my soundcard and rebooted and the installer went away (tried rebooting more than once with the soundcard in there to see if it was jst something rare).
i'm thinking maybe it is really dead now. lol

i'm using my onboard soundcard now, so we'll see just how long i can go without it crashing.
i usually leave my computer on day and night so it shouldn't take but a month or two to really know.
anwaypasible
Posts: 125
Joined: Tue Sep 04, 2012 8:59 am
Location: kankakee illinois
Contact:

Postby anwaypasible » Sun Mar 16, 2014 5:26 am

just got another bsod using the onboard realtek soundcard.
seems like it wasn't just my creative x-fi after all.

**edit**

i'm gonna try and have a talk with the asio4all people and see if they have anything to say.

it can't be virtual audio cable because it uses it's own engine.
it specifically gives the option to use portcls and i don't have it enabled.
anwaypasible
Posts: 125
Joined: Tue Sep 04, 2012 8:59 am
Location: kankakee illinois
Contact:

Postby anwaypasible » Tue Mar 18, 2014 7:41 am

this is what i got from the developer of asio4all


could asio4all cause a portcls.sys BSOD ?
It does not contain any kernel mode components, so: *no!*
anwaypasible
Posts: 125
Joined: Tue Sep 04, 2012 8:59 am
Location: kankakee illinois
Contact:

Re: BSOD portcls.sys

Postby anwaypasible » Fri Apr 04, 2014 1:16 am

just got another portcls.sys BSOD using the onboard soundcard
this one was strange, it happened right after the end of a commercial on pandora

is there some type of debug process i could follow?

really.. you haven't told me if liveprofessor can even cause a portcls.sys BSOD
if it can't .. i'll just stop bothering you about it (and be a little embarassed i put this much effort into talking to you about it)
:?:
nature.. time.. and patience are the three great healers
User avatar
nikolai
Posts: 1231
Joined: Fri Sep 04, 2009 1:05 pm
Location: Norway
Contact:

Re: BSOD portcls.sys

Postby nikolai » Sat Apr 05, 2014 9:41 am

Hi
Sorry for taking so long to get back to you.
No LiveProfessor makes no low-level calls that could cause blue-screen errors in it self.
At worst you would get A. an Access Violation message, B a Freeze or C a "This program has quit unexpectedly" message
That said LiveProfessor might trigger this to happen, like (this is just an example) it loads the audio driver that in turn loads a thing that loads a thing that causes a blue screen.
As far as I know blue-screens are usually caused by driver/memory/hardware issues.
In fact I once had a Dell computer that would blue screen at random times, just sitting idle at the windows log on screen. but only with a firewire audio card plugged in.

Regards
Nikolai
anwaypasible
Posts: 125
Joined: Tue Sep 04, 2012 8:59 am
Location: kankakee illinois
Contact:

Re: BSOD portcls.sys

Postby anwaypasible » Tue Aug 05, 2014 4:27 am

on a different motherboard.. (different cpu, different ram)
I got a bsod talking about portcls.sys again.

this time I'm using version 1.20 beta of liveprofessor (the 32bit version)
I'm also using the newly released asio4all driver

whatever it is.. maybe it happens to everybody trying to do what I do?
nature.. time.. and patience are the three great healers

Return to “LiveProfessor 1”

Who is online

Users browsing this forum: No registered users and 2 guests