Audio clicks when DSP lower than 20%

sfxter
Posts: 9
Joined: Tue Mar 13, 2018 10:06 am

Audio clicks when DSP lower than 20%

Postby sfxter » Thu Apr 19, 2018 10:28 pm

Hi everyone,
I have noticed strange thing. Although my DSP meter in LiveProfessor stays lower than 20% most of the time, I still get audio clicks and pops. And there is not to much plugins: 2 Slate triggers, 3 FabFilter eq, 2 Waves PSE, 3 C6 and an F6.
Tried turning off indexing and app sleep, but that did not helped either.
My PC is MacbookPro OS x 10.12.6 with Intel Core i7.
I tried it using Dante virtual soundcard and Dante Accelerator.
Buffer is set to 64 samples @ 48kHz.
My console is flooded with:

Code: Select all

HALC_ProxyIOContext.cpp:1068:IOWorkLoop:  HALC_ProxyIOContext::IOWorkLoop: skipping cycle due to overload
and

Code: Select all

IOAudioEngineUserClient[<private>]::performWatchdogOutput(<private>, 187784) - (105b,19b4)
is this normal. Does anyone else experience trouble with audio stability on os x?
sfxter
Posts: 9
Joined: Tue Mar 13, 2018 10:06 am

Re: Audio clicks when DSP lower than 20%

Postby sfxter » Mon Apr 23, 2018 1:25 pm

Not the most active forum as I see :)
but anyway, I will just post here my experiment. Looks like my OS X are set correctly and the computer is powerful enough, because I can load more plugin instances in Multirack Native until I get the same level of audio stability.

I have created this chain: Waves CLA-2A to API 2500 to L3 UltraMaximizer. Then I duplicated the same chain multiple times until I started receiving in console

IOAudioEngineUserClient[<private>]::performWatchdogOutput(<private>, 187784) - (105b,19b4)


In LiveProfessor it started after 12 duplicated chains. DSP load was about 25%
Multirack allowed me to create 24 duplicate chains until i started receiving the same message in console. DSP load was about 35%.


I dont want to say anything bad about LiveProfessor, because I really love the way it opens up more possibilities to use more plugins. But the stability is still an issue as well as CPU handling. Creators of this software already did an amazing job and have brilliant ideas, but I believe that other users as well as me, would love to see more stable release instead of new features.
Just my 2 cents.


Best regards.
User avatar
nikolai
Posts: 413
Joined: Fri Sep 04, 2009 1:05 pm
Location: Norway
Contact:

Re: Audio clicks when DSP lower than 20%

Postby nikolai » Wed Apr 25, 2018 8:19 am

Hi sorry for the late reply.
If you google the console output you posted here:
You get posts like these with other having the same issue:
https://discussions.apple.com/thread/77 ... 0&tstart=0
I have not researched it very much, but it seems to me that there is a firmware hardware issue here ?

Also as a side note, the DSP load "meters" can't really be compared, it just measures the time it takes to process all plugins. (more on that here if interested: https://goo.gl/ap2oZa)
Anyway, the fact that the issue is present in all audio applications suggest that you probably have to dig a bit deeper on this particular mac to sort out the problem.
sfxter
Posts: 9
Joined: Tue Mar 13, 2018 10:06 am

Re: Audio clicks when DSP lower than 20%

Postby sfxter » Wed Apr 25, 2018 10:56 am

Thank you for your answer, Nikolai. I would really love to use your application, because I find some features very helpful in a live gigs.

Maybe someone who have OS X could do this test and confirm the console output:

Start Dante Virtual Soundcard, set samplerate to 48000 and the buffer to 64 samples. At this condition, in console I see no "performWatchdogOutput" (easy to find when you type in Consoles search "watchdog").
When I change buffer size to 32 samples, my console is flooded with "performWatchdogOutput" (about 2000 messages per second).

Same test with built in output and input device gives totally different result.
Setting buffer to 32 samples almost does not output "performWatchdogOutput" messages (just few of them, while driver is changing).

I would really appreteate if anyone using Dante could try and reproduce this test on their machine.
patrass
Posts: 82
Joined: Tue May 04, 2010 1:48 am
Location: france

Re: Audio clicks when DSP lower than 20%

Postby patrass » Wed Apr 25, 2018 4:15 pm

i'm not on osx but on windows minimum buffer size with DVS depend on i/o count it's only possible with 2i/2o configuration with 32i/32o works fine with buffer size of 512 or 1024 sample and use lot of dsp... usable only for recording live session
the pci-e dante card work fine with large i/o count with low latency (tested with 32i/o with 32 sample buffer)
The Chainmaster
LX6464ES,RME AIO,BABYFACE,HDSP9652 AIC128D win8.1/32*64

Who is online

Users browsing this forum: Bing [Bot] and 1 guest